Cloud Platform
Support
Contact us

Adobe security alert.

March 9, 2021

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 8 vulnerabilities that were fixed in 3 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit Qualys Security Blog to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying Qualys Community Edition.

Vulnerability details

Adobe has released 3 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe Connect Arbitrary Code Execution Vulnerability (APSB21-19)

    Severity
    Serious 3
    Qualys ID
    12242
    Vendor Reference
    APSB21-19
    CVE Reference
    CVE-2021-21078, CVE-2021-21079, CVE-2021-21080, CVE-2021-21081, CVE-2021-21085
    CVSS Scores
    Base 6.8 / Temporal 5
    Description

    Adobe Connect (formerly Presedia Publishing System, Macromedia Breeze, and Adobe Acrobat Connect Pro) is software used to create information and general presentations, online training materials, web conferencing, learning modules and user desktop sharing.

    This update fixes security bug(s) in Adobe Connect.

    Affected Versions:
    Adobe Connect versions 11.0.5 and earlier

    QID Detection Logic (Unauthenticated):
    This QID reads the version.txt file in an unauthenticated request to see if it's vulnerable.

    Consequence

    An attacker could exploit this vulnerability to compromise Confidentiality, Integrity and/or Availability.

    Solution
    Customers are advised to follow the patch procedure provided by Adobe. Further more information can be obtained from APSB21-19

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB21-19

  • Adobe Framemaker Arbitrary Code Execution Vulnerability(APSB21-14)

    Severity
    Urgent 5
    Qualys ID
    375334
    Vendor Reference
    APSB21-14
    CVE Reference
    CVE-2021-21056
    CVSS Scores
    Base 9.3 / Temporal 6.9
    Description
    Adobe FrameMaker is a document processor designed for writing and editing large or complex documents, including structured documents.

    CVE-2021-21056: Arbitrary Code Execution

    Affected Versions:
    Adobe Framemaker 2019.0.8 and below.

    QID Detection Logic:
    This authenticated QID detects file versions of Adobe Framemaker (FrameMaker.exe).

    Consequence
    Allows attackers to execute the arbitrary code.

    Solution
    The vendor has released Adobe Framemaker patch version 2020.0.2. Please visit APSB21-14 for more details.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB21-14

  • Adobe Creative Cloud Desktop Application Multiple Vulnerabilities (ASPB21-18)

    Severity
    Critical 4
    Qualys ID
    375335
    Vendor Reference
    ASPB21-18
    CVE Reference
    CVE-2021-21068, CVE-2021-21069, CVE-2021-21078
    CVSS Scores
    Base 9.3 / Temporal 6.9
    Description
    Adobe Creative Cloud Desktop Application is your central location for managing the dozens of apps and services that are included in your Creative Cloud membership. You can also sync and share files, manage thousands of fonts, access libraries of stock photography and design assets.

    This update fixes security bugs in Adobe Creative Cloud Desktop Application.

    Affected Versions:
    Creative Cloud Desktop Application(old installer) 5.3 and earlier versions

    QID Detection Logic (authenticated):
    Operating System: Windows
    The QID checks vulnerable version of file "Creative Cloud Desktop App.exe".

    Consequence
    Successful exploitation of the vulnerability will lead to arbitrary code execution.
    Solution
    The vendor has released a patch Creative Cloud Desktop Application version 5.4
    For more information please visit ASPB21-18.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ASPB21-18

These new vulnerability checks are included in Qualys vulnerability signature 2.5.126-8. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 12242
    • 375334
    • 375335
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Platforms and Platform Identification

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.