Cloud Platform
Support
Contact us

Adobe security alert.

December 8, 2020

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 2 vulnerabilities that were fixed in 2 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit Qualys Security Blog to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying Qualys Community Edition.

Vulnerability details

Adobe has released 2 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe Prelude Arbitrary code execution Vulnerability (APSB20-70)

    Severity
    Serious 3
    Qualys ID
    374544
    Vendor Reference
    ASPB20-70
    CVE Reference
    CVE-2020-24440
    CVSS Scores
    Base 3.7 / Temporal 2.7
    Description
    Adobe Prelude is an ingest and logging tool for tagging media with metadata for searching, post-production workflows, and footage lifecycle management.

    These updates address critical vulnerabilities Arbitrary code execution in Adobe Prelude.

    Affected Versions:
    Adobe Prelude 9.0.1 and earlier versions

    QID Detection Logic:
    This QID checks Windows registry to see if Adobe Prelude is installed. If found, it checks if the installed versions is vulnerable.

    Consequence
    Successful exploitation could lead to arbitrary code execution in the context of the current user.
    Solution
    The vendor has released a patch for Adobe Prelude
    For more information please visit APSB20-70

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ASPB20-70

  • Adobe Lightroom Arbitrary Code Execution Vulnerability (APSB20-74)

    Severity
    Critical 4
    Qualys ID
    374545
    Vendor Reference
    ASPB20-74
    CVE Reference
    CVE-2020-24447
    CVSS Scores
    Base 3.7 / Temporal 2.7
    Description
    Adobe Lightroom is a RAW converter. When you add images, it manages the file type in the background. Lightroom supports images in all kinds of formats.

    This update addresses a critical vulnerability. Arbitrary code execution in Adobe Lightroom.

    Affected Versions:
    Adobe Lightroom Classic 10.0 and earlier versions.

    QID Detection Logic:
    This QID checks Windows registry to see if Adobe Lightroom Classic is installed. If found, it checks the installed versions is vulnerable or not.

    Consequence
    This vulnerability could be exploited to change contents or configuration on the system.
    Solution
    The vendor has released a patch for Adobe Prelude
    For more information please visit APSB20-74

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ASPB20-74

These new vulnerability checks are included in Qualys vulnerability signature 2.5.51-3. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 374544
    • 374545
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Platforms and Platform Identification

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.