Cloud Platform
Support
Contact us

Adobe security alert.

December 10, 2019

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 25 vulnerabilities that were fixed in 4 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit Qualys Security Blog to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying Qualys Community Edition.

Vulnerability details

Adobe has released 4 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe ColdFusion Privilege Escalation Vulnerability Detected (APSB19-58)

    Severity
    Critical 4
    Qualys ID
    13637
    Vendor Reference
    APSB19-58
    CVE Reference
    CVE-2019-8256
    CVSS Scores
    Base 7.5 / Temporal 5.9
    Description
    Adobe ColdFusion is an application for developing Web sites. It is available for various operating systems.

    Adobe ColdFusion is prone to Privilege Escalation vulnerability.

    Affected Versions:
    ColdFusion2018 Update 6 and earlier versions for all platform.

    QID Detection Logic (Authenticated):
    This QID checks to see if Adobe ColdFusion and a .JAR file required to mitigate this update are installed.

    Consequence
    By exploiting these vulnerabilities, an attacker can get sensitive information, execute arbitrary code.
    Solution
    The vendor has released patches to resolve this issue. Please apply Adobe Security Hotfix.

    Refer to APSB19-58 to obtain additional information on the vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-58

  • Adobe Security Update for Adobe Acrobat and Reader (APSB19-55)

    Severity
    Critical 4
    Qualys ID
    372283
    Vendor Reference
    APSB19-55
    CVE Reference
    CVE-2019-16444, CVE-2019-16445, CVE-2019-16446, CVE-2019-16448, CVE-2019-16449, CVE-2019-16450, CVE-2019-16451, CVE-2019-16452, CVE-2019-16453, CVE-2019-16454, CVE-2019-16455, CVE-2019-16456, CVE-2019-16457, CVE-2019-16458, CVE-2019-16459, CVE-2019-16460, CVE-2019-16461, CVE-2019-16462, CVE-2019-16463, CVE-2019-16464, CVE-2019-16465
    CVSS Scores
    Base 10 / Temporal 7.8
    Description

    Adobe Reader and Acrobat are applications for handling PDF files. Adobe Reader and Acrobat are prone to multiple vulnerabilities that could potentially allow an attacker to take control of an affected system.

    Affected Versions:
    Acrobat DC Continuous 2019.021.20056 and earlier versions
    Acrobat Reader DC Continuous 2019.021.20056 and earlier versions
    Acrobat 2017 Classic 2017 2017.011.30152 and earlier versions
    Acrobat 2017 Classic 2017 2017.011.30155 and earlier version
    Acrobat Reader 2017 Classic 2017 2017.011.30152 and earlier versions
    Acrobat 2015 Classic 2015 2015.006.30505 and earlier versions
    Acrobat Reader 2015 Classic 2015 2015.006.30505 and earlier versions

    QID Detection Logic (Authenticated):
    Operating System: Windows
    This QID looks for the vulnerable version of Acrobat.dll, AcroRd32.dll and nppdf32.dll files.

    QID Detection Logic (Authenticated):
    Operating System: MacOS
    This QID looks for the vulnerable version of Adobe Reader and Acrobat from the installed application list.

    Consequence

    An attacker could exploit this vulnerability to compromise Confidentiality, Integrity and/or Availability.

    Solution

    Adobe has released fix to address this issue. Customers are advised to refer to APSB19-55 for updates pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-55

  • Adobe Security Update for Photoshop (APSB19-56)

    Severity
    Critical 4
    Qualys ID
    372284
    Vendor Reference
    APSB19-56
    CVE Reference
    CVE-2019-8253, CVE-2019-8254
    CVSS Scores
    Base 9.3 / Temporal 6.9
    Description

    Adobe Photoshop is an application that allows users to view and edit various graphic formats. This update fixes security bug(s) in Adobe Photoshop.

    Affected Versions:
    Adobe Photoshop CC versions 20.0.7 and earlier 20.x versions
    Adobe Photoshop CC versions 21.0.1 and earlier 21.x versions

    QID Detection Logic:
    Windows(Authenticated): This QID checks for vulnerable version of 'Photoshop.exe' file.
    MacOS(Authenticated): This QID checks for vulnerable version of Photoshop on system

    Consequence

    An attacker could exploit this vulnerability to compromise Confidentiality, Integrity and/or Availability.

    Solution

    Adobe has released fix to address this issue. Customers are advised to refer to APSB19-56 for updates pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-56

  • Adobe Brackets Command Injection Vulnerability (APSB19-57)

    Severity
    Critical 4
    Qualys ID
    372285
    Vendor Reference
    APSB19-57
    CVE Reference
    CVE-2019-8255
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    Brackets is a source code editor with a primary focus on web development.

    Adobe has released a security update for Brackets for Windows, mac OS and Linux which resolves a command execution vulnerability.
    Affected Versions: Brackets 1.14 and earlier versions for Windows, mac OS.

    QID Detection Logic:(Authenticated)
    It checks the vulnerable version of Brackets by checking its file version.

    Consequence
    Successful exploitation could lead to arbitrary code execution in the context of the current user.
    Solution
    Adobe has released Brackets patch version 1.14.1 in APSB19-57

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ASBP19-57

These new vulnerability checks are included in Qualys vulnerability signature 2.4.765-4. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 13637
    • 372283
    • 372284
    • 372285
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Platforms and Platform Identification

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.