Cloud Platform
Community
Support

Microsoft security alert.

September 10, 2019

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 80 vulnerabilities that were fixed in 11 bulletins announced today by Microsoft. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit our blog to see how to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying Qualys Community Edition.

Vulnerability details

Microsoft has released 11 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Microsoft Windows Adobe Flash Player Security Update for September 2019 (ADV190022)

    Severity
    Critical 4
    Qualys ID
    100386
    Vendor Reference
    ADV190022
    CVE Reference
    CVE-2019-8069, CVE-2019-8070
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    The update contains security fixes for Adobe Flash Player on Internet Explorer.

    Affected Versions:
    Windows 10 Version 1507,Windows 10 Version 1607,Windows 10 Version 1703, Windows 10, Windows 10 Version 1803, Windows 10 Version 1809, Windows 10 Version 1903, Windows Server 2019,Windows Server 2016, Windows 8.1, Windows RT 8.1, Windows Server 2012,Windows Server 2012 R2 with Adobe Flash Player version prior to 32.0.0.255.

    QID Detection Logic:
    This authenticated QID will flag if file version of %windir%\System32\Macromed\Flash\Flash.ocx is less than 32.0.0.255.

    Consequence

    An attacker could exploit this vulnerability to compromise Confidentiality, Integrity and/or Availability.

    Solution
    Customers are advised to follow 4516115 for instructions pertaining to the remediation of this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ADV190022 Windows

  • Microsoft Internet Explorer Security Update for September 2019

    Severity
    Critical 4
    Qualys ID
    100387
    Vendor Reference
    KB4512578, KB4515384, KB4516026, KB4516044, KB4516046, KB4516055, KB4516058, KB4516065, KB4516066, KB4516067, KB4516068, KB4516070
    CVE Reference
    CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, CVE-2019-1208, CVE-2019-1220, CVE-2019-1221, CVE-2019-1236, CVE-2019-11091
    CVSS Scores
    Base 7.6 / Temporal 5.6
    Description
    Microsoft releases the security update for Internet Explorer September 2019

    The KB Articles associated with the update:
    KB4512578
    KB4515384
    KB4516044
    KB4516046
    KB4516055
    KB4516058
    KB4516065
    KB4516066
    KB4516067
    KB4516068
    KB4516070
    KB4516026
    QID Detection Logic:

    This QID checks for the file version of Mshtml.dll

    The following versions of Mshtml.dll with their corresponding KBs are verified:
    KB4516068 - 11.0.15063.2045
    KB4516067 - 11.0.9600.19463
    KB4516046 - 9.0.8112.21368 , 11.0.9600.19463 , 10.0.9200.22858
    KB4516026 - 9.0.8112.21368
    KB4516058 - 11.0.17134.1006
    KB4516055 - 10.0.9200.22858
    KB4515384 - 11.0.18362.356
    KB4516065 - 11.0.9600.19463
    KB4516066 - 11.0.16299.1387
    KB4512578 - 11.0.17763.737

    For KB4516044 and KB4516070 "urlmon.dll" is checked in the detection.

    Consequence
    An attacker who successfully exploited the vulnerability could gain the same user rights as the current user.
    Solution
    Please refer to the Security Update Guide for more information pertaining to these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Microsoft Security Update Guide Windows

  • Microsoft Office and Microsoft Office Services and Web Apps Security Update September 2019

    Severity
    Critical 4
    Qualys ID
    110338
    Vendor Reference
    KB4461631, KB4464548, KB4464557, KB4464566, KB4475566, KB4475574, KB4475579, KB4475583, KB4475589, KB4475590, KB4475591, KB4475594, KB4475596, KB4475599, KB4475605, KB4475607, KB4475611, KB4484098, KB4484099
    CVE Reference
    CVE-2019-1246, CVE-2019-1257, CVE-2019-1259, CVE-2019-1260, CVE-2019-1261, CVE-2019-1262, CVE-2019-1263, CVE-2019-1264, CVE-2019-1295, CVE-2019-1296, CVE-2019-1297
    CVSS Scores
    Base 9.3 / Temporal 6.9
    Description
    Microsoft has released September 2019 security updates to fix multiple security vulnerabilities.

    This security update contains the following KBs:
    KB4475611
    KB4475591
    KB4475599
    KB4484098
    KB4475590
    KB4475605
    KB4475596
    KB4484099
    KB4475594
    KB4464557
    KB4475574
    KB4475579
    KB4475566
    KB4475607
    KB4475583
    KB4464566
    KB4461631
    KB4475589
    KB4464548

    QID Detection Logic:
    This authenticated QID checks the file versions from above Microsoft KB article with the versions on affected office system.

    Consequence
    Successful exploitation allows an attacker to execute code remotely.
    Solution
    Refer to Microsoft Security Guidance for more details pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Microsoft Office and Microsoft Office Services and Web Apps Security Update September 2019

  • Microsoft Exchange Server Security Update for September 2019

    Severity
    Serious 3
    Qualys ID
    50095
    Vendor Reference
    KB4515832
    CVE Reference
    CVE-2019-1233, CVE-2019-1266
    CVSS Scores
    Base 4.3 / Temporal 3.2
    Description
    Microsoft has released an update for Microsoft Exchange Server that remediates for the following vulnerabilities:
    CVE-2019-1233: A denial of service vulnerability exists in Microsoft Exchange Server software when the software fails to properly handle objects in memory. Exploitation of the vulnerability requires that a specially crafted email be sent to a vulnerable Exchange server. The security update addresses the vulnerability by correcting how Microsoft Exchange Server handles objects in memory.
    CVE-2019-1266: A spoofing vulnerability exists in Microsoft Exchange Server when Outlook Web App (OWA) fails to properly handle web requests. To exploit the vulnerability, an attacker could send a specially crafted email containing a malicious link to a user. An attacker could also use a chat client to social engineer a user into clicking the malicious link. However, in both examples the user must click the malicious link. The security update addresses the vulnerability by correcting how OWA validates web requests.

    Affected Software:
    Microsoft Exchange Server 2016 Cumulative Update 12
    Microsoft Exchange Server 2016 Cumulative Update 13
    Microsoft Exchange Server 2019 Cumulative Update 1
    Microsoft Exchange Server 2019 Cumulative Update 2

    KB Articles covered: KB4515832.

    QID Detection Logic (authenticated):
    The QID checks for the version of file Exsetup.exe if it is lesser than:
    The version for Microsoft Exchange Server 2016 Cumulative Update 12 is 15.1.1713.9.
    The version for Microsoft Exchange Server 2016 Cumulative Update 13 is 15.1.1779.5.
    The version for Microsoft Exchange Server 2019 Cumulative Update 1 is 15.2.330.10.
    The version for Microsoft Exchange Server 2019 Cumulative Update 2 is 15.2.397.6.

    Consequence
    An attacker who successfully exploited the vulnerability could cause a remote denial of service against a system or redirect the user to a malicious website that could spoof content or the vulnerability could be used as a pivot to chain an attack with other vulnerabilities in web services.

    Solution
    Customers are advised to refer to KB4515832 for updates pertaining to these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    KB4515832

  • Microsoft Edge Security Update for September 2019

    Severity
    Critical 4
    Qualys ID
    91568
    Vendor Reference
    KB4512578, KB4515384, KB4516044, KB4516058, KB4516066, KB4516068, KB4516070
    CVE Reference
    CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, CVE-2019-1138, CVE-2019-1217, CVE-2019-1220, CVE-2019-1237, CVE-2019-1298, CVE-2019-1299, CVE-2019-1300, CVE-2019-11091
    CVSS Scores
    Base 7.6 / Temporal 5.6
    Description
    Microsoft releases the security update for Microsoft Edge September 2019

    The KB Articles associated with the update:
    KB4512578
    KB4515384
    KB4516044
    KB4516058
    KB4516066
    KB4516068
    KB4516070
    QID Detection Logic:

    This QID checks for the file version of edgehtml.dll

    The following versions of edgehtml.dll with their corresponding KBs are verified:
    KB4512578 - 11.0.17763.737
    KB4516066 - 11.0.16299.1387
    KB4516070 - 11.0.10240.18333
    KB4516058 - 11.0.17134.1006
    KB4515384 - 11.0.18362.356
    KB4516068 - 11.0.15063.2045

    For KB4516044 - "bingmaps.dll" is used in the detection with a patched version of 10.0.14393.3204

    Consequence
    An attacker who successfully exploited the vulnerability could gain the same user rights as the current user.
    Solution
    Please refer to the Security Update Guide for more information pertaining to these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Microsoft Security Update Guide Windows

  • Microsoft .NET Framework Security Updates for September 2019

    Severity
    Serious 3
    Qualys ID
    91570
    Vendor Reference
    KB4514354, KB4514355, KB4514356, KB4514357, KB4514359, KB4514598, KB4514599, KB4514601, KB4514603, KB4514604, KB4516044, KB4516058, KB4516066, KB4516068, KB4516070
    CVE Reference
    CVE-2019-1142
    CVSS Scores
    Base 2.1 / Temporal 1.6
    Description
    An elevation of privilege vulnerability exists when the .NET Framework common language runtime (CLR) allows file creation in arbitrary locations.

    KB4514354, KB4514355, KB4514356, KB4514357, KB4514359, KB4514598, KB4514599, KB4514601, KB4514603, KB4514604, KB4516044, KB4516058, KB4516066, KB4516068, KB4516070 kbs are covered.
    This security update is rated Important for supported versions of Microsoft .NET Framework.

    QID Detection Logic (Authenticated):
    - Checks for vulnerable version of Clr.dll, Mscorlib.dll files

    Consequence
    Successful exploitation allows attackers to write files to folders that require higher privileges than what the attacker already has.
    Solution
    Customers are advised to refer to CVE-2019-1142 for more details pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    CVE-2019-1142

  • Microsoft .NET Core Security Update September 2019

    Severity
    Serious 3
    Qualys ID
    91571
    Vendor Reference
    .NET Core
    CVE Reference
    CVE-2019-1301
    CVSS Scores
    Base 5 / Temporal 3.7
    Description
    .NET Core is a general purpose development platform maintained by Microsoft and the .NET community on GitHub. It is cross-platform, supporting Windows, macOS and Linux, and can be used in device, cloud, and embedded/IoT scenarios.

    A denial of service vulnerability exists when .NET Core improperly handles web requests.

    Affected versions
    .NET Core 2.1.0 prior to 2.1.13
    .NET Core 2.2.0 prior to 2.2.7

    Qid detection logic:Authenticated
    The qid checks for vulnerable dotnet.dll versions on windows and checks for vulnerable .net core versions on Linux and mac systems.

    Consequence
    An attacker who successfully exploited this vulnerability could cause a denial of service against a .NET Core web application.
    Solution
    Microsoft has released an update. Please refer to vendor security advisory .NET Core CVE-2019-1301 for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    .NET Core

  • Microsoft Windows Security Update for September 2019

    Severity
    Critical 4
    Qualys ID
    91572
    Vendor Reference
    KB4512578, KB4515384, KB4516026, KB4516033, KB4516044, KB4516051, KB4516055, KB4516058, KB4516062, KB4516064, KB4516065, KB4516066, KB4516067, KB4516068, KB4516070
    CVE Reference
    CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, CVE-2019-0787, CVE-2019-0788, CVE-2019-0928, CVE-2019-1214, CVE-2019-1215, CVE-2019-1216, CVE-2019-1219, CVE-2019-1232, CVE-2019-1235, CVE-2019-1240, CVE-2019-1241, CVE-2019-1242, CVE-2019-1243, CVE-2019-1244, CVE-2019-1245, CVE-2019-1246, CVE-2019-1247, CVE-2019-1248, CVE-2019-1249, CVE-2019-1250, CVE-2019-1251, CVE-2019-1252, CVE-2019-1253, CVE-2019-1254, CVE-2019-1256, CVE-2019-1267, CVE-2019-1268, CVE-2019-1269, CVE-2019-1270, CVE-2019-1271, CVE-2019-1272, CVE-2019-1273, CVE-2019-1274, CVE-2019-1277, CVE-2019-1278, CVE-2019-1280, CVE-2019-1282, CVE-2019-1283, CVE-2019-1284, CVE-2019-1285, CVE-2019-1286, CVE-2019-1287, CVE-2019-1289, CVE-2019-1290, CVE-2019-1291, CVE-2019-1292, CVE-2019-1293, CVE-2019-1294, CVE-2019-1303, CVE-2019-11091
    CVSS Scores
    Base 9.3 / Temporal 7.3
    Description
    Microsoft releases the security update for Windows September 2019

    The KB Articles associated with the update:
    KB4512578
    KB4515384
    KB4516026
    KB4516033
    KB4516044
    KB4516051
    KB4516055
    KB4516058
    KB4516062
    KB4516064
    KB4516065
    KB4516066
    KB4516067
    KB4516068
    KB4516070
    QID Detection Logic:

    This QID checks for the file version of ntoskrnl.exe

    The following versions of ntoskrnl.exe with their corresponding KBs are verified:
    KB4516068 - 10.0.15063.2045
    KB4516067 - 6.3.9600.19464
    KB4516070 - 10.0.10240.18333
    KB4516044 - 10.0.14393.3204
    KB4516051 - 6.0.6003.20625
    KB4516026 - 6.0.6003.20625
    KB4516058 - 10.0.17134.1006
    KB4516055 - 6.2.9200.22859
    KB4516033 - 6.1.7601.24520
    KB4515384 - 10.0.18362.356
    KB4516065 - 6.1.7601.24520
    KB4516062 - 6.2.9200.22859
    KB4516064 - 6.3.9600.19464
    KB4516066 - 10.0.16299.1387
    KB4512578 - 10.0.17763.737

    Consequence
    An attacker who successfully exploited this vulnerability could execute arbitrary code on a victim system.
    Solution
    Please refer to the Security Update Guide for more information pertaining to these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Microsoft Security Update Guide Microsoft Security Update Guide

  • Microsoft ASP.NET Core Security Update September 2019

    Severity
    Serious 3
    Qualys ID
    91573
    Vendor Reference
    ASP.NET
    CVE Reference
    CVE-2019-1302
    CVSS Scores
    Base 6.8 / Temporal 4.5
    Description
    An elevation of privilege vulnerability exists when a ASP.NET Core web application, created using vulnerable project templates, fails to properly sanitize web requests.

    Affected Versions:
    ASP.NET Core 2.1 prior to 2.1.2.
    ASP.NET Core 2.2 prior to 2.2.1.

    QID Detection Logic (Authenticated):
    This QID checks for the vulnerable version of Microsoft.AspNetCore.App and Microsoft.AspNetCore.All

    Consequence
    An attacker who successfully exploited this vulnerability could perform content injection attacks and run script in the security context of the logged-on user.
    Solution
    Microsoft has released an update. Please refer to vendor security advisory .NET Core CVE-2019-1302 for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ASP.NET

  • Microsoft Windows Servicing Stack Security Update September 2019

    Severity
    Medium 2
    Qualys ID
    91574
    Vendor Reference
    KB4511839, KB4512573, KB4512574, KB4512575, KB4512576, KB4512577, KB4512938, KB4512939, KB4515383, KB4516655, KB4517134
    CVE Reference
    N/A
    CVSS Scores
    Base 5.1 / Temporal 3.8
    Description
    Microsoft has released Servicing Stack security updates for Windows Server 2008 Service Pack 2 , Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1, Windows 10, Windows 10 Version 1607, Windows 10 Version 1703, Windows 10 Version 1709, Windows 10 Version 1803, Windows 10 Version 1809, Windows 10 Version 1903,Windows 8.1, Windows Server 2012, Windows Server 2012 (Server Core installation), Windows Server 2012 R2,Windows Server 2012 R2 (Server Core installation), Windows Server 2016,Windows Server 2016 (Server Core installation), Windows Server 2019, Windows Server 2019 (Server Core installation), Windows Server, version 1803 (Server Core Installation), Windows Server, version 1903 (Server Core installation)

    QID Detection Logic (Authenticated):
    This authenticated QID will check for file version of CbsCore.dll

    Consequence
    Successful exploitation allows attacker to compromise the system.
    Solution
    Customers are advised to refer to advisrory ADV990001for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    ADV990001

  • Microsoft Visual Studio Security Update for September 2019

    Severity
    Serious 3
    Qualys ID
    91575
    Vendor Reference
    CVE-2019-1232
    CVE Reference
    CVE-2019-1232
    CVSS Scores
    Base 4.6 / Temporal 3.4
    Description
    An elevation of privilege vulnerability exists when the Diagnostics Hub Standard Collector Service improperly handles certain file operations. To exploit this vulnerability, an attacker would require unprivileged access to a vulnerable system.

    Affected Software:
    Microsoft Visual Studio 2015 Update 3
    Microsoft Visual Studio 2017 Version 15.0
    Microsoft Visual Studio 2017 Version 15.9
    Microsoft Visual Studio 2019 Version 16.0
    Microsoft Visual Studio 2019 Version 16.2

    QID Detection Logic:
    This QID detects vulnerable versions of Microsoft Visual Studio by checking file version of StandardCollector.Service.exe.

    Consequence
    Successful exploitation of this vulnerability allows an attacker to gain elevated privileges on the system.
    Solution
    Customers are advised to refer to CVE-2019-1232 for more information pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    CVE-2019-1232

These new vulnerability checks are included in Qualys vulnerability signature 2.4.696-4. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 100386
    • 100387
    • 110338
    • 50095
    • 91568
    • 91570
    • 91571
    • 91572
    • 91573
    • 91574
    • 91575
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.