Cloud Platform
Community
Support

Adobe security alert.

April 9, 2019

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 32 vulnerabilities that were fixed in 5 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit our blog to see how to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying Qualys Community Edition.

Vulnerability details

Adobe has released 5 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe Reader and Acrobat Multiple Vulnerabilities (APSB19-17)

    Severity
    Serious 3
    Qualys ID
    371729
    Vendor Reference
    APSB19-17
    CVE Reference
    CVE-2019-7061, CVE-2019-7088, CVE-2019-7109, CVE-2019-7110, CVE-2019-7111, CVE-2019-7112, CVE-2019-7113, CVE-2019-7114, CVE-2019-7115, CVE-2019-7116, CVE-2019-7117, CVE-2019-7118, CVE-2019-7119, CVE-2019-7120, CVE-2019-7121, CVE-2019-7122, CVE-2019-7123, CVE-2019-7124, CVE-2019-7125, CVE-2019-7127, CVE-2019-7128
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    Adobe Acrobat is a family of application software and Web services developed by Adobe Inc. to view, create, manipulate, print, and manage files in Portable Document Format. The family comprises Acrobat Reader, Acrobat, and Acrobat.com.

    Adobe has released security updates to address the fix for Out-of-Bounds Read,Out-of-Bounds Write,Type Confusion,User After Free and Heap Overflow Vulnerabilities.

    Affected Versions:
    Acrobat DC Continuous 2019.010.20098 and earlier versions (Windows and macOS)
    Acrobat Reader DC Continuous 2019.010.20098 and earlier versions (Windows and macOS)
    Acrobat 2017 Classic 2017 2017.011.30127 and earlier version (Windows and macOS)
    Acrobat Reader 2017 Classic 2017 2017.011.30127 and earlier version (Windows and macOS)
    Acrobat DC Classic 2015 2015.006.30482 and earlier versions (Windows and macOS)
    Acrobat Reader DC Classic 2015 2015.006.30482 and earlier versions (Windows and macOS)

    QID Detection Logic (Authenticated):
    Operating System: Windows
    This QID looks for the vulnerable version of Acrobat.dll, AcroRd32.dll and nppdf32.dll files.

    QID Detection Logic (Authenticated):
    Operating System: MacOS
    This QID looks for the vulnerable version of Adobe Reader and Acrobat from the installed application list.

    Consequence
    Successful exploitation could lead to arbitrary code execution and disclose sensitive information.
    Solution
    The vendor has released patches in APSB19-17

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-17

  • Adobe Security Update for Flash Player (APSB19-19)

    Severity
    Critical 4
    Qualys ID
    371731
    Vendor Reference
    APSB19-19
    CVE Reference
    CVE-2019-7096, CVE-2019-7108
    CVSS Scores
    Base 10 / Temporal 7.4
    Description

    Adobe Flash Player is a Cross-platform plugin plays animations, videos and sound files in .SWF format.

    This update fixes security bug(s) in Adobe Flash Player.

    Affected Versions:
    Adobe Flash Player versions prior to 32.0.0.171

    QID Detection Logic :
    This QID checks for vulnerable version of Flash Player.

    Consequence

    An attacker could exploit this vulnerability to compromise Confidentiality, Integrity and/or Availability.

    Solution

    Adobe has released fix to address this issue. Customers are advised to refer to APSB19-19 for updates pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-19

  • Adobe Security Update for InDesign (APSB19-23)

    Severity
    Critical 4
    Qualys ID
    371732
    Vendor Reference
    APSB19-23
    CVE Reference
    CVE-2019-7107
    CVSS Scores
    Base 10 / Temporal 7.4
    Description

    Adobe InDesign is a desktop publishing software application. This update fixes security bug(s) in Adobe InDesign.

    Affected Versions:
    Adobe InDesign versions prior to 14.0.2

    QID Detection Logic:
    Windows(Authenticated): This QID checks Windows registry to see if Adobe InDesign is installed. If found, it checks if the installed versions is vulnerable.
    Mac OS(Authenticated): This QID looks for a vulnerable version of Adobe InDesign if any in System_Profiler.

    Consequence

    An attacker could exploit this vulnerability to compromise Confidentiality, Integrity and/or Availability.

    Solution

    Adobe has released fix to address this issue. Customers are advised to refer to APSB19-23 for updates pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-23

  • Adobe Security Update For Dreamweaver (APSB19-21)

    Severity
    Serious 3
    Qualys ID
    371733
    Vendor Reference
    APSB19-21
    CVE Reference
    CVE-2019-7097
    CVSS Scores
    Base 5 / Temporal 3.7
    Description
    Adobe Dreamweaver is a web design and development application that combines a visual design surface known as Live View and a code editor with standard features such as syntax highlighting, code completion, and code collapsing as well as more sophisticated features such as real-time syntax checking and code introspection for generating code hints to assist the user in writing code.

    This update resolves a vulnerability related to the use of the Server Message Block (SMB) protocol when handling UNC paths in Dreamweaver.

    Affected Versions:
    Adobe Dreamweaver 19.0 and earlier versions.

    QID Detection Logic (Authenticated):
    This QID checks for the vulnerable version of Adobe Dreamweaver .

    Consequence
    Sensitive data disclosure can occur if SMB request is subject to a relay attack.
    Solution

    Adobe has released fix to address this issue. Customers are advised to refer to APSB19-21 for updates pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-21

  • Adobe Shockwave Player Arbitrary Code Execution Vulnerability (APSB19-20)

    Severity
    Urgent 5
    Qualys ID
    371734
    Vendor Reference
    APSB19-20
    CVE Reference
    CVE-2019-7098, CVE-2019-7099, CVE-2019-7100, CVE-2019-7101, CVE-2019-7102, CVE-2019-7103, CVE-2019-7104
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    Adobe Shockwave Player is a multimedia player available for multiple platforms.

    This update resolves a Arbitrary Code Execution vulnerability due to memory corruption.

    Affected Versions:
    Adobe Shockwave Player 12.3.4.204 and earlier versions on the Windows operating system.

    QID Detection Logic (Authenticated):
    This QID checks Windows registry for vulnerable versions of Adobe Shockwave Player.

    Consequence

    Successful exploitation of this vulnerability will allow an attacker to execute arbitrary code on the system.

    Solution
    The vendor has released an update to resolve this issue. Adobe recommends that users install Shockwave Player version 12.3.5.205. The updated version is available for download at the Shockwave Player Download site.

    Refer to the vendor advisory APSB19-20 to obtain additional details about these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB19-20 Windows

These new vulnerability checks are included in Qualys vulnerability signature 2.4.576-4. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 371729
    • 371731
    • 371732
    • 371733
    • 371734
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.