Cloud Platform
Solutions
Subscriptions
Cloud platform apps
Customers
Partners
Community
Support
Company
Login

Adobe security alert.

November 14, 2017

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 79 vulnerabilities that were fixed in 5 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit our blog to see how to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying our FreeScan service.

Vulnerability details

Adobe has released 5 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe Connect Multiple Security Vulnerabilities (APSB17-35)

    Severity
    Serious 3
    Qualys ID
    11883
    Vendor Reference
    APSB17-35
    CVE Reference
    CVE-2017-11287, CVE-2017-11288, CVE-2017-11289, CVE-2017-11290, CVE-2017-11291
    CVSS Scores
    Base 5 / Temporal 3.7
    Description
    Adobe Connect (formerly Presedia Publishing System, Macromedia Breeze, and Adobe Acrobat Connect Pro) is software used to create information and general presentations, online training materials, web conferencing, learning modules and user desktop sharing.

    This update resolves below issues.
    - A critical Server-Side Request Forgery (SSRF) vulnerability
    - Three input validation vulnerabilities
    - This update includes a feature that enables Connect administrators to protect users from UI redressing (or clickjacking) attacks.

    Affected Versions:
    Adobe Connect 9.6.2 and earlier

    QID Detection Logic (Unauthenticated):
    This detection checks the version.txt file remotely for version information.

    Consequence
    Successful exploitation of these vulnerabilities could allow an attacker to bypass network access controls, conduct UI redressing or cross-site scripting attack.
    Solution
    Users are advised to follow the patch procedure provided by Adobe. Further more information can be obtained from APSB17-35

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB17-35

  • Adobe Reader and Acrobat Multiple Vulnerabilities (APSB17-36)

    Severity
    Critical 4
    Qualys ID
    370650
    Vendor Reference
    APSB17-36
    CVE Reference
    CVE-2017-11293, CVE-2017-16360, CVE-2017-16361, CVE-2017-16362, CVE-2017-16363, CVE-2017-16364, CVE-2017-16365, CVE-2017-16366, CVE-2017-16367, CVE-2017-16368, CVE-2017-16369, CVE-2017-16370, CVE-2017-16371, CVE-2017-16372, CVE-2017-16373, CVE-2017-16374, CVE-2017-16375, CVE-2017-16376, CVE-2017-16377, CVE-2017-16378, CVE-2017-16379, CVE-2017-16380, CVE-2017-16381, CVE-2017-16382, CVE-2017-16383, CVE-2017-16384, CVE-2017-16385, CVE-2017-16386, CVE-2017-16387, CVE-2017-16388, CVE-2017-16389, CVE-2017-16390, CVE-2017-16391, CVE-2017-16392, CVE-2017-16393, CVE-2017-16394, CVE-2017-16395, CVE-2017-16396, CVE-2017-16397, CVE-2017-16398, CVE-2017-16399, CVE-2017-16400, CVE-2017-16401, CVE-2017-16402, CVE-2017-16403, CVE-2017-16404, CVE-2017-16405, CVE-2017-16406, CVE-2017-16407, CVE-2017-16408, CVE-2017-16409, CVE-2017-16410, CVE-2017-16411, CVE-2017-16412, CVE-2017-16413, CVE-2017-16414, CVE-2017-16415, CVE-2017-16416, CVE-2017-16417, CVE-2017-16418, CVE-2017-16419, CVE-2017-16420
    CVSS Scores
    Base 6.8 / Temporal 5
    Description
    Adobe Reader and Acrobat are applications for handling PDF files. They are prone to multiple vulnerabilities that could potentially allow an attacker to take control of an affected system.

    Affected Software:
    Acrobat DC Continuous 2017.012.20098 and earlier versions for Windows and Macintosh
    Acrobat Reader DC Continuous 2017.009.20044 and earlier versions for Windows and Macintosh
    Adobe Reader XI 11.0.22 and earlier 11.x versions for Windows and Macintosh
    Acrobat DC Classic 2015.006.30355 and earlier versions for Windows and Macintosh
    Acrobat Reader DC Classic 2015.006.30355 and earlier versions for Windows and Macintosh
    Adobe Acrobat XI 11.0.22 and earlier 11.x versions for Windows and Macintosh
    Adobe Acrobat 2017 2017.011.30066 and earlier versions for Windows and Macintosh

    QID Detection Logic (authenticated):
    This QID looks for the vulnerable version of Acrobat.dll, AcroRd32.dll and nppdf32.dll files.

    Consequence
    Successful exploitation of these vulnerabilities could allow an attacker to take control of the affected system.
    Solution
    Users on Windows and Macintosh systems can utilize the Adobe product's update mechanism. The default configuration is set to run automatic update checks on a regular schedule.

    Refer to APSB17-36 for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB17-36

  • Adobe Shockwave Player Remote Code Execution Vulnerability (APSB17-40)

    Severity
    Urgent 5
    Qualys ID
    370652
    Vendor Reference
    APSB17-40
    CVE Reference
    CVE-2017-11294
    CVSS Scores
    Base 9 / Temporal 6.7
    Description
    Adobe Shockwave Player is a multimedia player available for multiple platforms.

    This update resolves a Remote Code Execution vulnerability due to memory corruption.

    Affected Versions:
    Adobe Shockwave Player 12.2.9.199 and earlier versions on the Windows operating system.

    QID Detection Logic (Authenticated):
    This QID checks Windows registry for vulnerable versions of Adobe Shockwave Player.

    Consequence

    Successful exploitation of this vulnerability will allow an attacker to execute arbitrary code on the system.

    Solution
    The vendor has released an update to resolve this issue. Adobe recommends that users install Shockwave Player version 12.2.8.198. The updated version is available for download at the Shockwave Player Download site.

    Refer to the vendor advisory APSB17-40 to obtain additional details about these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB17-40

  • Adobe Flash Player Remote Code Execution Vulnerability (APSB17-33)

    Severity
    Urgent 5
    Qualys ID
    370653
    Vendor Reference
    APSB17-33
    CVE Reference
    CVE-2017-3112, CVE-2017-3114, CVE-2017-11213, CVE-2017-11215, CVE-2017-11225
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    Adobe Flash Player is a Cross-platform plugin plays animations, videos and sound files in .SWF format.

    These vulnerabilities that could potentially allow an attacker to take control of the affected system. (CVE-2017-3112, CVE-2017-3114, CVE-2017-11213,CVE-2017-11215, CVE-2017-11225)

    Affected Versions:
    Adobe Flash Player 27.0.0.183 and earlier

    QID Detection Logic (Authenticated):
    This checks for vulnerable version of Adobe Flash Player.

    Consequence
    Successful exploitation allows a remote, unauthenticated attacker to execute arbitrary code on a targeted system.
    Solution
    Customers are advised to refer to APSB17-33 for updates pertaining to this vulnerability.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB17-33 MAC OS X
    APSB17-33 Windows

  • Adobe Digital Editions Multiple Vulnerabilities (APSB17-39)

    Severity
    Serious 3
    Qualys ID
    370654
    Vendor Reference
    APSB17-39
    CVE Reference
    CVE-2017-11273, CVE-2017-11297, CVE-2017-11298, CVE-2017-11299, CVE-2017-11300, CVE-2017-11301
    CVSS Scores
    Base 7.5 / Temporal 5.5
    Description

    Adobe Digital Editions is an ebook reader software program from Adobe Systems built using Adobe Flash with support for acquiring, managing and reading eBooks, digital newspapers, and other digital publications. The software supports PDF, XHTML, and Flash-based content.

    Adobe Digital Editions is prone to multiple out-of-bound reads, memory corruption and information disclosure vulnerabilities.

    Affected Versions:
    Adobe Digital Editions 4.5.6 and earlier versions for Windows and Macintosh

    QID Detection Logic (Authenticated):
    This QID checks Windows registry for vulnerable versions of Adobe Digital Editions.

    Consequence

    Depending on the vulnerability exploited, an attacker can execute arbitrary code on the system,retrieve sensitive information or disclose memory addresses.

    Solution

    Adobe has released a patch to fix this vulnerability. User are advised to upgrade to the latest version of software available. The latest version can be downloaded from here

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB17-39

These new vulnerability checks are included in Qualys vulnerability signature 2.4.195-3. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 11883
    • 370650
    • 370652
    • 370653
    • 370654
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.