Search

See Resources

Security Alerts

Oracle Critical Patch Update Advisory - January 2017

Advisory Overview

Qualys® Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 40 vulnerabilities that were fixed in 6 bulletins announced today by Oracle. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit our blog to see how to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying our FreeScan service.

Vulnerability Details

Oracle has released 6 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Oracle Database January 2017 Security Update Multiple Vulnerabilities (CPUJAN2017)

    Severity
    Critical 4
    Qualys ID
    20031
    Vendor Reference
    CPUJAN2017
    CVE Reference
    CVE-2017-3310, CVE-2017-3240
    CVSS Scores
    Base 6 / Temporal 4.4
    Description
    Oracle released a Critical Patch Update advisory for January 2017 that addresses several security vulnerabilities.

    The following Oracle database component are affected:
    - OJVM
    - RDBMS Security

    Consequence
    An attacker could affect the confidentiality, integrity and availability of data on the target system.
    Solution
    Oracle recommends that customers upgrade to the latest supported version of Oracle products in order to obtain the patches.
    Read Oracle Critical Patch Update Advisory - January 2017 for further information about the products affected and issues addressed.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    CPUJAN2017 Oracle Database (Database)

  • Oracle Database January 2017 Patch Set Update (PSU) 12.1.0.2.170117 Not Installed (Patch 24732082)

    Severity
    Critical 4
    Qualys ID
    20030
    Vendor Reference
    CPUJAN2017
    CVE Reference
    CVE-2017-3310, CVE-2017-3240
    CVSS Scores
    Base 6 / Temporal 4.4
    Description
    Oracle Database Patch Set Updates are proactive cumulative patches containing recommended bug fixes that are released on a regular schedule.

    Affected Software:
    Oracle Database 12.1.0.2

    Consequence
    Failure to apply this patch could lead to loss of the integrity of the database.
    Solution
    Customers are requested to refer to CPUJAN2017 to obtain details about how to deploy the update.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Patch 24732082

  • Oracle Database January 2017 Patch Set Update (PSU) 11.2.0.4.170117 Not Installed (Patch 24006111)

    Severity
    Critical 4
    Qualys ID
    20028
    Vendor Reference
    CPUJAN2017
    CVE Reference
    CVE-2017-3310
    CVSS Scores
    Base 6 / Temporal 4.4
    Description
    Oracle Database Patch Set Updates are proactive cumulative patches containing recommended bug fixes that are released on a regular schedule.

    Affected Software:
    Oracle Database 11.2.0.4

    Consequence
    Failure to apply this patch could lead to loss of the integrity of the database.
    Solution
    Customers are requested to refer to CPUJAN2017 to obtain details about how to deploy the update.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Patch 24006111

  • Oracle Java SE Critical Patch Update - January 2017

    Severity
    Urgent 5
    Qualys ID
    370280
    Vendor Reference
    Oracle Java SE CPU January 2017
    CVE Reference
    CVE-2016-2183, CVE-2016-5546, CVE-2016-5547, CVE-2016-5548, CVE-2016-5549, CVE-2016-5552, CVE-2016-8328, CVE-2017-3231, CVE-2017-3241, CVE-2017-3252, CVE-2017-3253, CVE-2017-3259, CVE-2017-3260, CVE-2017-3261, CVE-2017-3262, CVE-2017-3272, CVE-2017-3289
    CVSS Scores
    Base 6.8 / Temporal 5.3
    Description
    Java Runtime Environment (JRE) is a platform that supports the execution of programs that are developed using the Java programming language. The JRE platform also supports Java Applets, which can be loaded from Web pages.

    JRE and JDK are exposed to multiple vulnerabilities that affect various components. Oracle's Java Critical Patch Update for January 2017 contains 16 new security fixes across multiple Java SE products and sub-products.

    Affected Versions:
    Oracle Java JDK and JRE, versions 6u131 and earlier, 7u121 and earlier, 8u112 and earlier.

    Consequence
    Exploitation could allow an attacker to take complete control of an affected system.
    Solution
    The vendor released updates (Java SE JDK and JRE 8 Update 121 or later, Java SE JDK and JRE 7 Update 131, Java SE JDK and JRE 6 Update 141) to resolve these issues.

    Refer to vendor advisory Oracle Java SE CPU January 2017 and Oracle Doc ID 2219954.1 to obtain more details.

    Updates for Java 5, Java 6 and Java 7 are no longer available to the public. Oracle offers updates to Java 5 and Java 6 only for customers who have purchased Java support or have Oracle products that require Java 5, Java 6 and Java 7.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Oracle Critical Patch Update Advisory - January 2017 (Java)
    Oracle Critical Patch Update Advisory - January 2017 (Java)

  • Oracle MySQL January 2017 Critical Patch Update (CPUJAN2017)

    Severity
    Critical 4
    Qualys ID
    20029
    Vendor Reference
    MySQL CPU January 2017
    CVE Reference
    CVE-2017-3312, CVE-2017-3258, CVE-2017-3244, CVE-2017-3238, CVE-2017-3313, CVE-2017-3317, CVE-2017-3318, CVE-2017-3291, CVE-2017-3265, CVE-2016-8318, CVE-2017-3273, CVE-2017-3257, CVE-2016-8327, CVE-2017-3243, CVE-2017-3256, CVE-2017-3251, CVE-2017-3319, CVE-2017-3320
    CVSS Scores
    Base 4.9 / Temporal 3.8
    Description
    This Critical Patch Update contains 18 new security fixes for Oracle MySQL.

    Affected Versions:
    MySQL Server, version(s) 5.5.53 and prior, 5.6.34 and prior, 5.7.16 and prior

    Consequence
    Successful exploitation could allow an attacker to affect the confidentiality, integrity and availability of data on the target system.
    Solution
    Refer to vendor advisory Oracle MySQL January 2017.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Oracle MySQL January 2017

  • Solaris 11.3 Support Repository Update (SRU) 16.3.0 Missing

    Severity
    Critical 4
    Qualys ID
    296008
    Vendor Reference
    Oracle Solaris 11.3 SRU 16.3.0
    CVE Reference
    CVE-2017-3276, CVE-2016-8330, CVE-2017-3301
    CVSS Scores
    Base 4.3 / Temporal 3.2
    Description
    The target does not have Solaris 11.3 SRU 16.3.0 applied. The Support Repository Updates provide patch bundles/updates that primarily contain bug fixes.
    Consequence
    Exploitation could allow an attacker to compromise a vulnerable system.
    Solution
    Apply Solaris 11.3 SRU 16.3.0 . Refer to Oracle Solaris 11.3 Support Repository Updates (SRU) Index for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    Oracle Solaris 11.3 SRU 16.3.0 Solaris

These new vulnerability checks are included in Qualys vulnerability signature 2.3.522-3. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 20031
    • 20030
    • 20028
    • 370280
    • 20029
    • 296008
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.

Email or call us at +1 800 745 4355 or try our Global Contacts
Subscription Packages
Qualys Solutions
Qualys Community
Company
Free Trial & Tools
Popular Topics