Cloud Platform
Solutions
Subscriptions
Cloud platform apps
Customers
Partners
Community
Support
Company
Login

Adobe security alert.

August 14, 2012

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 26 vulnerabilities that were fixed in 3 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit our blog to see how to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying our FreeScan service.

Vulnerability details

Adobe has released 3 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe Reader and Acrobat Multiple Vulnerabilities (APSB12-16)

    Severity
    Critical 4
    Qualys ID
    120295
    Vendor Reference
    APSB12-16
    CVE Reference
    CVE-2012-1525, CVE-2012-2049, CVE-2012-2050, CVE-2012-2051, CVE-2012-4147, CVE-2012-4148, CVE-2012-4149, CVE-2012-4150, CVE-2012-4151, CVE-2012-4152, CVE-2012-4153, CVE-2012-4154, CVE-2012-4155, CVE-2012-4156, CVE-2012-4157, CVE-2012-4158, CVE-2012-4159, CVE-2012-4160, CVE-2012-4161, CVE-2012-4162
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    Adobe Acrobat and Reader are applications for handling PDF files. Adobe Acrobat and Reader are prone to a variety of buffer overflow and memory corruption vulnerabilities.

    Affected Softwares:
    Adobe Reader X (10.1.3) and earlier 10.x versions for Windows and Macintosh
    Adobe Reader 9.5.1 and earlier 9.x versions for Windows and Macintosh
    Adobe Acrobat X (10.1.3) and earlier 10.x versions for Windows and Macintosh
    Adobe Acrobat 9.5.1 and earlier 9.x versions for Windows and Macintosh

    Note: Previously this was an iDefense exclusive vulnerability with iDefense ID: 771072.

    Consequence
    If this vulnerability is successfully exploited, an attacker can execute arbitrary code with the privileges of the user viewing a Web page or opening a PDF file.
    Solution
    Adobe recommends users of Adobe Reader X (10.1.4) and earlier versions for Windows and Macintosh update to Adobe Reader X (10.1.4). For users of Adobe Reader 9.5 and earlier versions for Windows and Macintosh, who cannot update to Adobe Reader X (10.1.4), Adobe has made available the update Adobe Reader 9.5.2. Adobe recommends users of Adobe Acrobat X (10.1.4) for Windows and Macintosh update to Adobe Acrobat X (10.1.4). Adobe recommends users of Adobe Acrobat 9.5 and earlier versions for Windows and Macintosh update to Adobe Acrobat 9.5.2.

    Refer to Adobe Security Bulletin ABSB12-16 for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB12-16 Adobe Acrobat - Macintosh(Acrobat)
    APSB12-16 Adobe Acrobat - Windows(Acrobat)
    APSB12-16 Adobe Reader - Macintosh(Reader)
    APSB12-16 Adobe Reader - Windows(Reader)

  • Adobe Shockwave Player Multiple Vulnerabilities (APSB12-17)

    Severity
    Critical 4
    Qualys ID
    120409
    Vendor Reference
    APSB12-17
    CVE Reference
    CVE-2012-2043, CVE-2012-2044, CVE-2012-2045, CVE-2012-2046, CVE-2012-2047
    CVSS Scores
    Base 10 / Temporal 7.4
    Description
    Adobe Shockwave Player is a multimedia player available for multiple platforms. It is prone to the following vulnerabilities:

    Multiple memory corruption vulnerabilities that could lead to code execution.

    Affected Versions:
    Adobe Shockwave Player 11.6.5.635 and earlier versions on the Windows and Macintosh.

    Consequence
    Successfully exploiting these vulnerabilities might allow a remote attacker to execute arbitrary code.
    Solution
    The vendor has released an update to resolve this issue. Adobe recommends Shockwave Player users install Shockwave Player version 11.6.6.636. The updated version is available for download at the Shockwave Player Download site.

    Refer to the vendor advisory APSB12-17 to obtain additional details about these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB12-17 Macintosh(Shockwave)
    APSB12-17 Windows(Shockwave)

  • Adobe Flash Player Remote Code Execution Vulnerability (APSB12-18)

    Severity
    Urgent 5
    Qualys ID
    120408
    Vendor Reference
    APSB12-18
    CVE Reference
    CVE-2012-1535
    CVSS Scores
    Base 9.3 / Temporal 8.1
    Description
    Adobe Flash Player is a multimedia application for multiple platforms.

    Adobe Flash Player is exposed to a vulnerability (CVE-2012-1535) that could cause the application to crash and potentially allow an attacker to take control of the affected system.

    Adobe reports that the vulnerability is being exploited in the wild in limited targeted attacks, distributed through a malicious Word document. The exploit targets the ActiveX version of Flash Player for Internet Explorer on Windows.

    Consequence
    Exploitation could allow an attacker to cause a denial of service or cause arbitrary execution of code to take control of a vulnerable system.
    Solution
    Users of Adobe Flash Player 11.3.300.270 and earlier versions for Windows and Macintosh should update to Adobe Flash Player 11.3.300.271.

    Users of Adobe Flash Player 11.2.202.236 and earlier versions for Linux should update to Adobe Flash Player 11.2.202.238.

    Refer to vendor advisory APSB12-18 for more information.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB12-18 Windows, Mac, Linux(Adobe Flash Player)

These new vulnerability checks are included in Qualys vulnerability signature 2.2.199-3. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 120295
    • 120409
    • 120408
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.