Cloud Platform
Solutions
Subscriptions
Cloud platform apps
Customers
Partners
Community
Support
Company
Login

Adobe security alert.

May 11, 2010

Advisory overview

Qualys Vulnerability R&D Lab has released new vulnerability checks in the Qualys Cloud Platform to protect organizations against 18 vulnerabilities that were fixed in 1 bulletins announced today by Adobe. Customers can immediately audit their networks for these and other new vulnerabilities by accessing their Qualys subscription. Visit our blog to see how to prioritize remediation.

Non-Qualys customers can audit their network for these and other vulnerabilities by signing up for a Qualys Free Trial, or by trying our FreeScan service.

Vulnerability details

Adobe has released 1 security bulletins to fix newly discovered flaws in their software. Qualys has released the following checks for these new vulnerabilities:

  • Adobe Shockwave Player Remote Code Execution Vulnerability (APSB10-12)

    Severity
    Critical 4
    Qualys ID
    118031
    Vendor Reference
    APSB10-12
    CVE Reference
    CVE-2010-0127, CVE-2010-0128, CVE-2010-0129, CVE-2010-0130, CVE-2010-0986, CVE-2010-0987, CVE-2010-1280, CVE-2010-1281, CVE-2010-1282, CVE-2010-1283, CVE-2010-1284, CVE-2010-1286, CVE-2010-1287, CVE-2010-1288, CVE-2010-1289, CVE-2010-1290, CVE-2010-1291, CVE-2010-1292
    CVSS Scores
    Base 9.3 / Temporal 7.3
    Description
    Adobe Shockwave Player is a multimedia player available for multiple platforms. It is prone to the following vulnerabilities:

    A boundary error vulnerability that if exploited, could lead to memory corruption and possible code execution (CVE-2010-0127).

    A signedness error vulnerability that could lead to code execution (CVE-2010-0128).

    Multiple memory corruption vulnerabilities due to integer overflow that could lead to code execution (CVE-2010-0129).

    An integer overflow vulnerability that could lead to code execution (CVE-2010-0130).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-0986).

    A buffer overflow vulnerability that could lead to code execution (CVE-2010-0987).

    Multiple memory corruption vulnerabilities that could lead to code execution (CVE-2010-1280).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1281).

    An infinite loop vulnerability that could lead to a denial of service (CVE-2010-1282).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1283).

    Multiple memory corruption vulnerabilities that could lead to code execution (CVE-2010-1284).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1286).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1287).

    A buffer overflow vulnerability that could lead to code execution (CVE-2010-1288).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1289).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1290).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1291).

    A memory corruption vulnerability that could lead to code execution (CVE-2010-1292).

    Shockwave Player 11.5.6.606 and earlier versions for Windows and Macintosh are affected.

    Consequence
    Successfully exploiting these vulnerabilities might allow a remote attacker to execute arbitrary code.
    Solution
    The vendor has released an update to resolve this issue. Adobe recommends Shockwave Player users install Shockwave Player version 11.5.7.609. The updated version is available for download at the Shockwave Player Download site.

    Refer to the vendor advisory APSB10-12 to obtain additional details about these vulnerabilities.

    Patches:
    The following are links for downloading patches to fix these vulnerabilities:
    APSB10-12 Mac OS(Adobe Shockwave Player)
    APSB10-12 Windows(Adobe Shockwave Player)

These new vulnerability checks are included in Qualys vulnerability signature 1.26.63-3. Each Qualys account is automatically updated with the latest vulnerability signatures as they become available. To view the vulnerability signature version in your account, from the Qualys Help menu, select the About tab.

Selective Scan Instructions Using Qualys

To perform a selective vulnerability scan, configure a scan profile to use the following options:

  1. Ensure access to TCP ports 135 and 139 are available.
  2. Enable Windows Authentication (specify Authentication Records).
  3. Enable the following Qualys IDs:
    • 118031
  4. If you would like the scan to return the Windows Hostname, also include QID 82044 and ensure access to UDP port 137 is available.
  5. If you would like to be notified if Qualys is unable to log on to a host (if Authentication fails), also include QID 105015.

In addition, prior to running a scan for these new vulnerabilities, you can estimate your exposure to these new threats by running the Risk Analysis Report, available from the Qualys Vulnerability Management Reports tab.

Access for Qualys Customers

Technical Support

For more information, customers may contact Qualys Technical Support.

About Qualys

The Qualys Cloud Platform and its integrated suite of security and compliance applications provides organizations of all sizes with a global view of their security and compliance solutions, while drastically reducing their total cost of ownership. Qualys solutions include: continuous monitoring, vulnerability management, policy compliance, PCI compliance, security assessment questionnaire, web application scanning, web application firewall, malware detection and SECURE Seal for security testing of web sites.