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Welcome

Welcome to Qualys SCAP Auditor, the cloud-based computing solution for Security Content 
Automation Protocol (SCAP) compliance. SCAP requires federal agencies to standardize the 
configuration of computer systems to strengthen IT security. This user guide will walk you 
through completing your first SCAP scans and creating reports showing your SCAP compliance. 

Qualys SCAP Auditor 1.2

Qualys SCAP Auditor 1.2 is a subscription based, Software as a Service solution delivered via 
Qualys Policy Compliance 8.x and the Qualys Cloud Platform. The SCAP features are versioned 
independently from other services available via the Qualys portal. Changes to the Qualys SCAP 
Auditor version number will indicate changes related to SCAP scanning. Qualys SCAP Auditor 
1.2 supports USGCB scanning for internal systems on a global scale.

For more information about Qualys SCAP Auditor 1.2, please visit the following site:

https://www.qualys.com/solutions/compliance/scap/

Tell me about availability

The SCAP application must be enabled for your account. Not sure if it’s enabled? Go to Help > 
Account Info and see if there’s a SCAP Summary section. If yes, then SCAP is turned on.

You’ll also need compliance management permissions. All Managers and Auditors have this 
permission. For sub-users, a Manager can grant you the “Manage PC module” permission by 
editing your user account.

SCAP compliance

Compliant with SCAP version 1.2: XCCDF 1.2, OVAL 5.10, CCE 5, CPE 2.3, CVE, and CVSS 2, 
OCIL 2.0, CCSS 1.0, Asset Identification 1.1, ARF 1.1, TMSAD 1.0

Compliant with SCAP version 1.0/1.1: XCCDF 1.1.4, OVAL 5.3, CCE 5,CPE 2.2, CVE, and CVSS 2

SCAP 1.2 conformance

Our SCAP application conforms with requirements in the SCAP 1.2 specification for the use case 
compliance checking (with the @use-case attribute in the <ds:data-stream> element set to 
CONFIGURATION). We are a consumer of SCAP content, meaning we accept existing SCAP 
source data stream content, process it, and produce valid SCAP result data streams.

SCAP 1.2 certification

Authenticated Configuration Scanner with the CVE option for assessment of Windows 7 (32 and 
64 bit) and Red Hat Enterprise Linux (RHEL) 5 Desktop (32 and 64 bit) providing the ability to 
audit and assess a target system to determine its compliance with USGCB requirements.

https://www.qualys.com/solutions/compliance/scap/
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Backward compatibility

SCAP Auditor 1.2 provides backward compatibility with SCAP 1.0 for assessment of Windows 
XP and Windows Vista supporting USGCB and FDCC assessment. We are certified for these 
capabilities for SCAP 1.0: FDCC Scanner, Authenticated Configuration Scanner, Authenticated 
Vulnerability and Patch Scanner, and Unauthenticated Vulnerability Scanner.

Additional assessment capabilities

In addition to the SCAP certified assessment capabilities, SCAP Auditor can process SCAP tier III 
content intended for the following systems: Windows 7 (32 and 64 bit), Windows XP (32 bit), 
Windows Vista, Windows 2008, Windows 2012, RHEL 5 (32 and 64 bit) and most Linux 
distributions. 

Where can I learn more?

Please refer to “Statement of SCAP Compliance” in the online help. Log in to the Qualys user 
interface, go to Help > Online Help and use the Search feature to find this help file.
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Set Up Policies

We provide pre-defined SCAP policies that are compliant with SCAP requirements 1.0 or 1.2. You 
can easily import one of these policies from our SCAP Policy Library. All SCAP policies in the 
library have been validated by the NIST standards. Also you can create a custom policy by 
uploading your own SCAP or OVAL content. 

What do I need to get started?

Compliance hosts in your account

Make sure the hosts you want to check for compliance are defined in your account as Compliance 
Hosts. Go to PC > Assets > Host Assets and you’ll see the compliance hosts (IP addresses) already 
in your account. You can add compliance hosts (up to the limit for your license) by selecting  
New > IP Tracked Hosts.

Asset groups with compliance hosts

When you import or create a policy, you’ll need to assign asset groups to the policy. The asset 
groups include the compliance hosts you want to scan against the policy. Go to Assets > Asset 
Groups > New > Asset Group to add one.

How to import a policy from the library

Go to PC > Policies and select New > Import SCAP Policy. Then click the Import button for the 
SCAP policy you want. 
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An import status appears like this and we recommend you assign assets now. Be sure to assign 
asset groups with relevant hosts (for example, add Windows 7 hosts to a Windows 7 policy).

How to create a policy with SCAP 1.2 content

Go to PC > Policies and select New > SCAP Policy. 

Select the option “SCAP version 1.2” and browse to the data stream collection file. Click Next.
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We’ll perform schema validation. Any errors will be reported online and must be resolved to 
continue. Upon successful validation, you’ll see SCAP benchmark details. Use the drop-downs to 
select the source data stream ID, the benchmark ID and the profile title (which corresponds to the 
profile ID) intended for evaluation. Important - Once you save the policy, you cannot modify 
these selections. You can, however, create new policies with different selections. Click Create to 
add the policy to your account. 

As stated earlier, you’ll need to assign assets to your policy if you want to scan against it. We 
recommend you do this now. After selecting asset groups click Assign Assets.

How to create a policy with SCAP 1.1/1.0 content

The steps are similar to version 1.2 described above. In this case, you’ll select the option “SCAP 
version 1.1/1.0” in the New SCAP Policy window. Then select the XCCDF content file plus 
additional data files. Click Next and we’ll perform schema validation. Please resolve any content 
errors reported online. Once you pass schema validation, select a SCAP benchmark - you can 
customize the details if you want. Click Create to save your new policy. Next assign assets to your 
policy and you’ll be ready to scan.
8
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How to create a policy with OVAL content

To create a SCAP policy with OVAL content, you’ll select the option “Custom OVAL definitions & 
external variables” in the New SCAP Policy window. Then select content to be uploaded - an 
OVAL definition file and optionally an OVAL external variable file. Click Next. 

The benchmark is automatically generated for your policy. The policy will be added to your 
account with the type OVAL once you click Create.

Next assign assets to your policy and you’ll be ready to scan. 
9



Start Scanning

SCAP Scanning analyzes the SCAP compliance of hosts on your network. When you launch 
SCAP scans, the service safely and accurately measures compliance against a SCAP policy using 
its Inference-Based Scanning Engine, an adaptive process that intelligently runs only tests 
applicable to each host scanned. 

What do I need to get started?

Scanner Appliance enabled for SCAP scanning

The SCAP option must be enabled on a scanner appliance to support SCAP scanning. 

Check the appliance software version - The scanner appliance must be running software version 
2.4 or later. You’ll find the version number in your account by going to the appliances list (Scans > 
Appliances) and viewing the appliance info (select the appliance, then select Info from the Quick 
Actions menu). You can also find the software version in the appliance user interface. On the 
main menu select VERSION INFO.

Edit the appliance settings - Go to PC > Scans > Appliances. Edit the appliance you want to use 
for SCAP scanning. Select the “Enable SCAP” option and then click Save.

Authentication records for your target hosts

Authentication to hosts is required for SCAP scans using an account with Administrator rights. 
You’ll want to add the credentials to be used for scanning in an authentication record. Go to PC > 
Scans > Authentication. Select New > Windows Record or New > Unix Record. You’ll be 
prompted to enter your credentials and target hosts. Tip - Click the Launch Help link within the 
record for help with the settings.

How to start a scan

Go to PC > Scans > SCAP Scans and select New > Scan.
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The Launch SCAP Scan wizard appears, prompting you to enter scan settings.

1. Select a SCAP policy to be evaluated by the scan. The menu lists all SCAP policies defined in 
your account. Click the View link to see the current settings for a selected policy.

2. Select a compliance profile to apply to this SCAP scan. Configuration settings defined in the 
compliance profile will affect your results. The menu is empty until you (or another user in the 
subscription) create a compliance profile. 

3. Select a scanner appliance that has been enabled for SCAP scanning. 

Click the Launch button after entering information. 

You can track the scan status on the SCAP Scans list. You will receive a scan summary email 
notification when the scan completes if this notification option is turned on in your account. 
11



Qualys SCAP Auditor Getting Started Guide
Start Scanning
Tell me about scan results

Sample SCAP scan results are below. 

You’ll notice the Appendix includes: Hosts Scanned/Not Scanned, Host Technology Not in 
Policy (CPE mismatch), Hostname Not Found, Windows authentication was successful/not 
successful, and compliance profile settings.
12
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Tips:

Once your scan is finished and scan results are processed, you can launch SCAP reports to 
determine whether hosts are compliant with a SCAP policy. Keep reading to learn how to launch 
SCAP compliance reports.

Tell me about “No data found”. If you run a SCAP scan and it returns the status “Finished” with 
the message “No data found” it’s most likely that authentication was not successful on the target 
hosts. Be sure to create authentication records for the systems you want to scan. Also check that 
the credentials in the records are current. 

How to verify that authentication worked

We recommend you run the Authentication Report to determine whether authentication was 
successful for all of the target hosts. Authentication must be successful in order for us to evaluate 
each host for SCAP compliance. To run this report go to PC > Reports and select New > 
Compliance Report > Authentication Report.

How to schedule your scans

By scheduling scans you’ll get SCAP scan results on a regular basis (daily, weekly or monthly) 
and during a time window convenient for your organization. It’s easy to schedule a scan. Just go 
to PC > Scans > Schedules and select New > Schedule Scan > SCAP.
13



Reporting

Specialized SCAP compliance reports provide the SCAP status of hosts in your account, based on 
the most recent SCAP scan results. These reports help you determine whether hosts are 
compliant with the SCAP policies in your account.

Go to PC > Reports to create new SCAP reports from the New menu (except the SCAP ARF report 
which is launched from the API). SCAP reports are described below.

SCAP Scorecard Report

The SCAP Scorecard Report gives you a high-level summary of the current SCAP compliance 
status of a SCAP policy in your account. To run this report go to PC > Reports, select New > 
SCAP Report > Scorecard Report, select settings and click Run.

Sample SCAP Scorecard Report:
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SCAP Policy XML Report

The SCAP Policy XML Report determines an organization’s compliance with the SCAP mandate 
for compliance hosts in a selected SCAP policy. To create this report go to PC > Reports and select 
New > SCAP Report > Policy Report, and choose the XCCDF TestResult (XML) format. Once you 
click Run we’ll create your report and you’ll see it in the reports list. 

Sample SCAP Policy XML Report:

The areas of the XCCDF specification that have been constrained for use with the SCAP profile 
appear in <TestResult> elements and <rule-result> sub-elements. 

SCAP Policy CSV Report

You can also run the SCAP Policy Report in CSV format. This allows you to import the data to 
external systems or to open the data in spreadsheet format. Simply choose the CSV format when 
running your report.

Sample SCAP Policy CSV Report: 
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Rule Pass/Fail Report

The Rule Pass/Fail Report identifies the SCAP compliance status for a particular rule. When you 
run this report, you’ll specify a SCAP policy and a rule from that policy to report on. Go to PC > 
Reports, select New > SCAP Report > Interactive > Rule Pass/Fail and click Run. 

The report setup window prompts you to select report settings. Once you click Run the 
completed report appears in the same window. 

Tips:

Use the Display option to filter the hosts displayed in the report based on posture. You have these 
options: Passed (Fixed), Failed (includes Error and Unknown) or Ignored (includes Not 
Applicable, Not Checked, Not Selected and Informational). 

You can modify the report settings to change the report output in real-time. Go to View > Setup 
Pane from within the report. Modify the settings and click Run to update the results. 

Interactive reports are not saved to your reports list. You can download and print the report from 
the File menu within your report.
16
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Sample Rule Pass/Fail Report: 

Each host in the report is listed on a separate line with the posture for the selected rule. 

How is posture determined? 

Our service evaluates the test results for all the nodes (definitions and test sections) according to 
the rule and determines whether the host satisfied the conditions of the rule.

Passed - The test results for all the nodes satisfied the conditions of the rule.

Failed - In a case where the evidence has a node with the result Error or Unknown, our service 
will assign the posture Failed since the host did not satisfy the conditions of the rule. If the result 
is Error, you’ll see Failed (Error). If the result is Unknown, you’ll see Failed (Unknown).

A rule is ignored if you see one of these postures: Not Applicable, Not Checked, Not Selected or 
Informational. Not Checked indicates that the rule refers to checks in checking systems other than 
OVAL. This includes OCIL checks.

How do I find the Patches Report?

The rule titled “Security Patches Up-To-Date” provides evidence for special patches tested during 
the most recent SCAP scan of each host in the SCAP policy. These include all patches defined in 
the “patches” file in the SCAP policy when present. For each host you’ll see the patch status. The 
status Pass indicates the patch was found during the last SCAP scan on the host, and the status 
Fail (in Red) indicates the patch was not found during the last SCAP scan on the host.
17
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Individual Host Report

The Individual Host Report identifies the SCAP compliance status for a particular host. When 
you run this report, you’ll specify a SCAP policy and a single host to report on.

Go to PC > Reports, select New > SCAP Report > Interactive > Individual Host and click Run.

The report setup window prompts you to select report settings.
 

18
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Sample Individual Host Report: 

Each rule from the SCAP policy that is applicable to the host is listed with the posture and 
posture evidence when included. 

Interested in OVAL definitions?

If you ran your report on a policy with custom OVAL definitions, you can go to File > Download 
to download the OVAL definitions in XML format. 
19
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SCAP ARF Report

You can launch a SCAP scan report in Asset Reporting Format (ARF) using our API, a 
requirement in the SCAP 1.2 specifications from NIST. 

How do I launch this report?

Use the SCAP ARF Report API v2 (the resource /api/2.0/fo/compliance/scap/arf/). You’ll need 
to provide the scan ID for a finished SCAP scan and optionally IPs if you want to limit the report 
to certain IP addresses only.

Not sure how to find the scan ID? You’ll see the scan ID when viewing SCAP scan results in the 
user interface. In the scan results window’s title bar you’ll see the report URL with its ID number 
in the “id” parameter, like this:

https://quaysguard.qualys.com/fo/report/fdcc/fdcc_scan_result.php?id=3362251

API Request

Here’s a sample API request:

curl -u "USERNAME:PASSWORD" -H "X-Requested-With: Curl" -X POST -d 
"scan_id=3362251&ips=10.10.10.1-10.10.10.10" 
"https://qualysapi.qualys.com/api/2.0/fo/compliance/scap/arf/"

https://qualysapi.qualys.com is the API server URL for US Platform 1. If your account is located 
on one of our other cloud platforms then you’ll want to replace this base URL with the one that is 
appropriate for your location. For example, for US Platform 2, use 
https://qualysapi.qg2.apps.qualys.com. For the EU Platform, use https://qualysapi.qualys.eu. If 
you have an @Customer platform, use a URL like https://qualysapi.<customer_base_url>.

XML Output

The XML output is compliant with the ARF 1.1 Schema. Show me the Schema

Where can I learn more about using the API?

Refer to the API V2 User Guide for a better understanding of API conventions and detailed 
instructions on using API functions. Get the latest from the Community. Go to the Community

Contact Support

Qualys is committed to providing you with the most thorough support. Through online 
documentation, telephone help, and direct email support, Qualys ensures that your questions 
will be answered in the fastest time possible. We support you 7 days a week, 24 hours a day. 
Access online support information at www.qualys.com/support/. 
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